	An Excel Primer

	
	
	

	
	The Basics
	

	
	
	

	
	Loading Excel

Excel is loaded in the same way as any other Windows application namely by selecting 
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 from the Start/All Programs Menu

or

by double-clicking on the Excel shortcut icon  [image: image2.jpg]Mirasoft
Excel



 (if there is one) on your desktop.


	

	
	
	

	
	The Excel Workspace
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	The Excel workspace contains many of the same elements of all Microsoft Office products as well as introducing a few specialized spreadsheet elements. The picture above indicates the major elements.

Title Bar: Displays the name of the application and the currently active workbook.

Menu Bar: Displays the set of drop down menus that give access to Excel’s features.
Tool Bar: Displays a set of buttons and drop down lists that give shortcuts to selected menu options or quick ways of entering data. This bar is configurable by selecting it with the right mouse button and then selecting the required option from the list displayed. (Note that the more toolbar options you display the less work area you will have available)

Formula Bar: Displays the data you enter into your worksheet. 

Name Box: Displays the reference of the Active Cell.

Row & Column Headings: Displays the row or column number.#
Active Cell: The active cell is indicated by having a Black border.

	

	
	Status Bar: Displays messages about  the current task.
	

	
	Sheet Tabs: Allows you to move between worksheets. 
	

	
	
	

	
	Moving Around in Excel

There are many ways to make a specific cell the active cell in Excel. Most users click with their mouse on an active cell. However, like all Microsoft Office products there are keyboard shortcuts for moving around on a spreadsheet:
[UP ARROW] or [SHIFT] + [ENTER] Moves the active cell up one row 

[DOWN ARROW] or [ENTER] Moves the active cell down one row 

[LEFT ARROW] or [SHIFT] + [TAB] Moves the active cell one to the left 

[RIGHT ARROW] or [TAB] Moves the active cell one to the right 

[PAGE DOWN] Moves the active cell one screen down 

[PAGE UP] Moves the active cell one screen up 

[ALT] + [PAGE DOWN] Moves the active cell one screen right 

[ALT] + [PAGE UP] Moves the active cell one screen left 

[HOME] Moves the active cell to the first cell in the row 

[END] Moves to the last active cell in a row 

[CTRL] + [HOME] Moves to cell A1 

[CTRL] + [END] Moves to the intersection of the last active row and column 

[F5] or Click in the Name Box Allows user to enter a cell address and go directly to it 


	

	
	
	

	
	Selecting Cells 

Before it is possible to enter/edit or format data it is necessary to select the cells required. Highlighting cells involves clicking-and-dragging across the cells you want selected.  The mouse pointer (or cursor) changes shape dependant upon where in the cell the selection is made. The following shows the options available.
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To select cells, the pointer should be a thick, white plus sign
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To Move cells, the pointer should be a north-south-east-west facing arrow
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If the pointer is a double arrow with a perpendicular line, the column or row it is pointed to (Column C in this example) will be resized
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If the pointer is a black plus sign, it indicates that the AutoFill handle is selected.
Rows or columns can be selected by clicking on the row or column heading. Using [SHIFT] with the arrow keys will highlight cells as will clicking on a cell in the corner of what you want selected, then holding down the [SHIFT] key and clicking on the cell in the opposite corner of the area you want selected. Multiple ranges can be selected after the first by holding down the [CTRL] key while selecting these ranges. 


	

	
	
	

	
	Cell Addresses

Each worksheet in Excel is consists of a grid comprising of 16,777,216 individual cells. There are 256 columns identified by letters ( A..Z, AA..AZ, BA..BZ, etc until the 256th column IV) and 65,536 rows identified by numbers. Each cell is identified by its column/row number, much like a map reference, as shown below.
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	It is also possible to refer to a cell on another worksheet within the same workbook by prefacing the cell reference with the Sheet name and an exclamation mark. E.g. to reference cell D6 on Sheet2 you would enter Sheet2!D6. It is also possible to reference a cell in a completely different workbook prefacing the Sheet name with the workbook path. E.g. 'C:\Temp\[test1.xls]Sheet1'!$A$1. Note that the $ symbol before the row/column reference indicate that the reference is an absolute reference. Absolute references will be covered later in this primer.
	

	
	
	

	
	Entering and Editing Data
	

	
	
	

	
	Entering Data 
Data can be entered into any cell of the worksheet. When entered the data will appear in the cell and in the formula bar. The data that is entered into a cell can be a number, text or a formula. Formulas must begin with an equals (=) character. Formulas will be dealt with more fully in a later section. Some things to remember about entering and editing cells:
When entering or editing text, you can cancel your edit by clicking the red X to the left of the formula bar or by pressing the [ESC] key. To accept the entry, either click the green check mark or move off of the cell (either by selecting another cell or by pressing the [TAB] or [ENTER] key). 
By default when you type text into a cell it will automatically align to the left of the cell. Numeric values align to the right side of a cell.  The alignment of data within cells will be covered further in the Formatting section.
You can edit the contents of a cell by double-clicking the cell, or click the cell, then click the insertion point at the place you wish in the formula bar 
To delete the contents of cells - highlight the cell(s) to be deleted and press the [DELETE] key.
	

	
	
	

	
	AutoFill
If you have to enter a series of items e.g. consecutive months, quarters, or dates then Excel can fill these in for you with the AutoFill Handle. The AutoFill Handle is a small black square at the lower right corner of the active cell. Your pointer will display as a black plus sign when you're on it.  When you click-and-drag the AutoFill handle, the computer will complete the series for you. If two cells are highlighted that have a constant increase or decrease in value Excel will detect this and AutoFill the remaining cells for you.
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If you right-drag the mouse when auto-filling a shortcut menu of options on how to AutoFill the selection will be displayed.
	

	
	
	

	
	Moving and Copying Cells
Excel allows you to move or cells to another position. To move cells, highlight the range of cells you wish to move, point to the border of the range (your pointer should turn into the standard Windows pointer) and click-and-drag the range to the new position.  E.g.
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Can be dragged to 
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Copying cells is a similar operation with one important difference. The [CTRL] key must be pressed down before you start clicking and dragging, and then kept depressed until the cells are in the new position. IF THE [CTRL] KEY IS RELEASED BEFORE THE MOUSE THE ACTION BECOMES A MOVE INSTEAD OF A COPY.
As with other Microsoft Office applications there are also buttons on the toolbar and selections under the Edit menu for cut, copy, and paste.
	

	
	
	

	
	Resizing Columns and Rows
If the text in a column is too wide for the size of the column, it will be truncated, whilst numbers will appear as a series of # (hash) characters. You can resize columns or rows by clicking and dragging on the column border (or below the row border). If you double click next to the column or row border it will automatically be resized to fit the widest entry. You can also resize columns (or rows) by selecting the required operation from the to the Format menu. If you wish to resize more than one column or row at a time you must highlight them first.
If you change the font of a cell to a different size, the height of the row will adjust automatically. 

When you resize a column or row, you are resizing the ENTIRE column. You CANNOT adjust the width or height of individual cells
	

	
	
	

	
	Formatting Data
	

	
	
	

	
	The cells in a worksheet can be formatted to display different fonts, font sizes, and colors. A quick way to format cells is via the FORMATTING TOOLBAR which allows you to format selected cells at the click of a button. You can format individual cells, a selection of cells, complete rows or columns. If the Format tool bar is not visible, right click in the menu bar and select Formatting from the list displayed.
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The buttons enable you to text font and size, make text bold, italic, underlined, change the alignment of the cell, text color, and cell background color. There are also buttons for formatting numbers for currency, comma, percentage, and to regulate the number of decimal places displayed. If you place your mouse pointer over a toolbar button and wait for a second or two a tooltip will be displayed that will tell you the purpose of the button. You can also access the functionality of the buttons and more via the Format menu or by selecting the cells and pressing the right mouse button and then selecting Format Cells… from the menu displayed.
Format Painter [image: image14.png]



You can quickly copy the formats of one cell to another with the Format Painter button. Click on the cell containing the formats you wish to copy, then click the Format Painter button on the Standard Toolbar, finally drag over the cells that you want to format.
	

	
	
	

	
	Page Setup and Print Preview
	

	
	
	

	
	It is always a good idea to check your Page Setup and to view your work with Print Preview before printing out your work. Excel can detect the printable area of your spreadsheet automatically but Page Setup allows you much closer control over how your work is printed. Selecting Page Setup from the File menu will display a dialog box with 4 tab sheets on it. 
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The Page Tab allows you to select the page orientation and the scaling of the page. Care need to be taken when using the Fit to: option as with large amounts of data the resultant output may be to small to read.
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	The Margins tab lets you setup the margins on the page and also the header and footer. If your spreadsheet won't fill an entire page you can also choose to centre it on the page horizontally, vertically, or both.
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	The Header/Footer Tab allows you to specify what is actually displayed in the Header and or Footer. You can select a pre-determined option from Header: or Footer: drop down lists or create your own via the Custom Header… or Custom Footer… buttons.
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	The Sheet tab allows you to select the exact area that should print if you should wish to print only a part of your worksheet. You can choose whether to print Row and column headings, turn on and off the gridlines, add comments, or determine the page order.
	

	
	
	

	
	Print Preview [image: image19.png]



Selecting the Print Preview button from the toolbar, Print Preview from the File menu or Print Preview from the Page Setup dialog box will allow you to preview your spreadsheet before sending it to the printer.
	

	
	
	

	
	Saving your work
	

	
	
	

	
	Eventually you will want to save your work so that you can edit it or review it at a later date. As with most operations within Excel you can do this in more than one way. You can either

1. Click the Save [image: image20.jpg]


 button on the standard toolbar

2. Press [CTRL] + S

3. Select Save from the File Menu
	

	
	
	

	
	If you have not saved before the Save As dialog box will be displayed. Click in the File Name box and enter a suitable name of your choice and then click Save.
	

	
	
	

	
	Eventually you may have a spreadsheet that you wish to use as a base for future work. Rather than starting from scratch you can save the existing worksheet under a different name and then change the newly named file to suit your purposes. To save your worksheet with a different name simply select Save As from the File Menu.  Carry out the same operation as detailed above when saving for the first time.
	

	
	
	

	
	Working with Formulas and Functions
	

	
	
	

	
	Formulas are the crucial feature of a Excel as they allow different values to be entered into the worksheet and Excel will automatically calculate the result. Besides doing the basic arithmetical operations Excel can also do more sophisticated calculations – scientific, financial, statistical – by offering a wealth of predefined Functions.
	

	
	
	

	
	Creating a Formula
Given the following worksheet
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To enter the total number of sales for Jan we could simply select cell C10 and enter

=100+75+50+60 – Note that Formulas ALWAYS being with the = (equals) sign.

This would give us the correct answer but what would happen if one of the values changed? As we had entered the values directly cell C10 would not be updated – the value displayed would then be incorrect. To over come this problem we could enter the Cell references
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Now if one of the values in cells C5, C6, C7 or C8 is changed the total displayed in C10 will be automatically updated.

Remember that when carrying out arithmetical calculations you will need to use parenthesis to ensure that the operations are carried out in the correct order
	

	
	
	

	
	Copying Formulas 

When we have established our formula it is quite often the case that we need to do a similar operation elsewhere in the worksheet – in the example given above we would also want to total Feb, Mar and Apr. The formula is the same – just the cell references will change. Excel allows you to copy formulas to other columns and rows and it will automatically adjust the cell references for you. This is called Relative Cell Referencing. 
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To copy a cell you can either use copy & paste or the AutoFill handle.
	

	
	
	

	
	Functions

In the previous example it would be very tedious to have to type the entire formula for the sum if there were many values to be entered. To save a lot of work Excel provides the SUM function amongst the more than 300 predefined functions that it has to offer.  When entering functions you must use the following form

=FUNCTION NAME(Argument)  (Note the = (equals) sign again)
The argument is the data required by the function to complete it. The argument could be a range of cells, specific numbers, text, or even another function. What is placed between the parentheses varies depending on the function and the situation it is being used in
In our example we could enter into cell C10

=SUM(C5 + C6 + C7 + C8) or to simplify even further

=SUM(C5:C8) – the : (colon) character between C5 and C8 denoting a range of cells

As summing data is a common operation Excel provides a special button on the toolbar to assist us. To use the AutoSum button [image: image24.jpg]


 simply click on the cell immediately to the right or below a series of numbers and then click on the AutoSum button.  
Other functions
To access the other functions available within Excel click on the black arrow adjacent to the AutoSum button and select More Functions… from the menu displayed. Important Note. This applies to Excel 2002 and higher. In previous versions u must select the Paste Function [image: image25.png]


 button. The following dialog button will be displayed
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Note that the dialog shown applies to Excel 2002 – earlier versions have minor differences but operate in the same way.
Once the required function has been selected another dialog will be displayed to allow you to enter the required arguments.
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The dialog box will preview the result of the function before you have to accept it. This provides the opportunity to make changes without going into Edit mode. Note that the argument can be anything from static numbers to a range of cells to another function. When the third of these is done, that is considered NESTING a function
Absolute Cell References

As previously stated, when a formula or function is copied or moved to another location, any cell references in the formula or function get adjusted as well. However situations occur where a cell reference inside a formula must ALWAYS refer to the same cell. Here's an example:
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Check out what happens when the formula is cut and pasted to cells D4 and E4
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You must use ABSOLUTE CELL REFERNCES for cell I3 in the original formula. This will lock the I3 reference in place. Then, when the formula is copied to columns D & E, the VAT in those columns will be multiplied by the VAT Rate in cell I3. 

To fix the formula in cell C4: 

Click in the formula bar on the I3 reference in the formula (clicking directly between the column and row reference usually works best) 

Press the [F4] key on your keyboard 

(NOTE: if you know the formula needs an absolute cell reference before you have typed it in, you can press [F4] as you are typing the reference) 

The I3 cell reference in the formula will now look like $I$3. The dollar signs locks the references (one $ for the column, one for the row) Continuously hitting the [F4] key will add and remove the respective dollar signs, allowing you to lock only the row, only the column, both, or neither. 

After the formulas have been corrected the spreadsheet looks like this:
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	Presenting Your Data
	

	
	
	

	
	Excel makes it easy to present the data you have entered into your worksheet by providing the Chart Wizard.  To create a Chart or Graph in Excel usually takes just a few steps…

1. Select your data on the worksheet

2. Select the Chart Wizard button [image: image31.jpg]


 from the toolbar.

3. Selects the style of Chart or graph that you require.

4. Enter Title and axis labels

5. Save the Chart.

Enter the following data into a new spreadsheet document…
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	Select the data and then select the Chart Wizard icon from the tool bar – the Chart Type page of the wizard will be displayed.
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	This page displays a list of 14 standard chart types and 20 custom chart types, with each option having up to seven variations. Selecting “Press and Hold to View Sample” will show a sample chart of the selected data.

Accept the default column chart and press the Next button. The Chart Source Data page of the wizard will be displayed…
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	This page allows you to select or modify the range that contains the data for the chart. You can also elect to have the row headings or column headings as the series. In our example the row headings represent the four different  bars in the chart. The legend identifies each set of bars. Selecting the Series tab allows you to edit the different data sets in the chart and change the Category (X) Axis labels. Selecting Next again displays the Chart Options wizard page…
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	This page gives options to enhance the chart by inserting titles, adding gridlines, reposition the legend, add data labels and embed a copy of the source data. Any changes made are reflected by corresponding changes to the chart displayed on the wizard page. Note that the number and content of the tabs on this page differ, dependant upon the chart type chosen. Selecting Next will display the final step of the wizard, the Chart Location page…
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	This page allows you to select the location of the completed chart. You can have the chart displayed as a new worksheet within the workbook or on any other worksheet within the workbook. If placed on its own sheet the chart can be printed as a separate page.

The resulting chart of our data follows…
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	Editing Charts
Once a chart has been created you can make any changes you wish to it – even changing the chart type if you wish. The Chart toolbar (below) can help with this. If it is not visible it can be displayed by selecting Chart from the View->Toolbars menu.
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	The relevant chart component can be selected by picking from the drop-down list or by selecting the item directly from the chart. Once selected it can be formatted via the Format menu or pressing the right mouse button and choosing the appropriate option displayed.  As an example – to change the appearance of the “North” data series we could do the following…

1. Select Series North from the drop down list. Small “grabbers” will appear in the centre of each “North” bar.

2. Select Format Data Series” from the Format menu. The Format Data Series dialog box will be displayed…
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	3. We will make the bar “hatched” by selecting Fill Effects…
The Fill Effects dialog box will be displayed…
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	4. Select the Pattern Tab and then select a suitable Foreground and Background colour and a Pattern from the options displayed. Remember that you may not always be printing to a colour printer so it is important to chose your colours and patterns with this in mind.


5. Select OK on the Fill Effects dialog box and then OK on the Format Data Series dialog box. The changed Chart is displayed below…
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Remember that any aspect of the chart can be changed after it has been created so whatever mistake has been made – it can easily be corrected!


	








