	An SPSS Primer

	
	
	

	
	The Basics
	

	
	
	

	
	Loading SPSS
SPSS is loaded in the same way as any other Windows application, namely by selecting 
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 from the Start/All Programs Menu

or

by double-clicking on the SPSS shortcut icon [image: image2.jpg]ol
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 (if there is one) on your desktop.


	

	
	
	

	
	The SPSS Workspace
	

	
	On clicking the SPSS icon a new window will appear on the screen. It has the familiar Windows menu bar – and the standard grid like interface of a spreadsheet type program.

[image: image3.jpg]E=|Untitled - SPSS Data Editor,
Fie Edt Vew Data Transforn Ansies Graphs biies Window Help

5| B o] 5] k| o £ BslEF o
[

\Data View £ Variabie View /. el
5pS5 Processor is ready





As you can see the menu bar contains some familiar options – along with a few that are SPSS specific. By default the toolbar is also displayed (although this can be turned off via the View->Toolbars… option so if your window does not display the toolbar you can switch it on there).
The default display shows an empty data sheet. Data can either be entered directly or by opening previously saved data via the File->Open->Data menu.
	

	
	
	

	
	Entering Data
	

	
	The default data view shows a grid containing rows labeled var . If data is entered directly into the grid SPSS will automatically rename the variable column, starting at var0001 and increasing sequentially as data is entered into each column. This is not usually very useful however, so it is good practice to define your variables before entering the data. 
	

	
	
	

	
	Defining Variables
	


	
	Switch to Variable View by double clicking the var column header or selecting the Variable View tab at the bottom of the workspace
[image: image4.jpg]2 Untitled - SPSS Data Editor.
Fie Edt Vew Dats Transforn Ansiyee Grophs bities Window rHelp

5] @] o] 5 =[] ] Elr] T 5 @]
[

{

ata View {Variabie View / 1Ll
5PS5 Processor fsready





SPSS will switch to Variable View
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This view allows us to define the attributes of our variables, namely

1. Name

a meaning full name for the variable – limited to 8 characters beginning with a letter.
2. Type

the type of variable. Clicking on the ellipses (the three little dots) that appear when you position the cursor in the column will display a dialog box enabling you to choice a variety of types including numeric, string(alphanumeric), currency and date. The default is Numeric.
3. Width

the total number of characters. The default is 8.
4. Decimals
the number of characters after the decimal place. The default is 2.
5. Label

Variable labels are used to attach a more meaningful name to your variable to overcome the limit of 8 lowercase alphanumeric characters.

6. Values

Value labels are used to attach labels to the value of coded data. E.g. if a variable describes the gender of a subject the value 1 might be labeled “Male” and the value 2 labeled “Female”.
7. Missing
allows you to designate certain scores are missing.

8. Columns
allows you to change the maximum number of characters in a column. The default is 8.

9 Align
determines how the data is aligned. The default is right for numeric, left for strng (alphanumeric) data.
10. Measure
allows you to select scale, ordinal or nominal data. The default is scale for numeric data, nominal for string data.

Assuming we have some data containing the name, gender and age of a group of post-graduate students. To set up the variable to contain the name data…
1. Enter a suitable Name. name would seem a good choice here!

2. Set the Type. In this case we select String. You will note you can also set the number of characters (11) at this stage. If you do it here you can miss out step 3.

3. Set the Width. Set to 11 ( the longest name in out data set).

4. Set the Label. Type Name of post-graduate student as the label value.

5. Set the Columns. Set this to 11 to match the width value.
You will notice that the Decimal columns are disabled. As we have a String variable these columns are not appropriate.

Similarly to set the variable for the gender data…
1. Enter a suitable Name. gender would seem appropriate.
2. Set the Type. In this case we select Numeric. You will note you can also set the Width (1) and Decimal Places (0) at this stage. If you do it here you can miss out steps 3 & 4.

3. Set the Width. Set to 1 ( 1 = Male, 2 = female).

4. Set the Decimals. Set to 0. gender will be an integer value.

5. Set the Label. Type Gender of post-graduate student as the label value.

6. Set the Values. We now assign value labels as follows
Click on the ellipses (…). In the dialog box displayed enter
1 as the Value and Male as the Value Label then click Add
2 as the Value and Female as the Value Label then click Add
Select Ok
It is generally better to used numeric codes for data like gender etc. as string variables can only be used in a limited number of SPSS procedures, and so severely limits your options for further data analysis.

7. Set the Columns. Set this to 6. i.e. the length of the longest Value Label
8. Set the Measure. Leave at the default Nominal.

Finally we can set up the age variable…


1. Enter a suitable Name. age would seem appropriate.

2. Set the Type. In this case we select Numeric. You will note you can also set the Width (2) and Decimal Places (0) at this stage. If you do it here you can miss out steps 3 & 4.

3. Set the Width. Set to 2 ( all ages < 100).

4. Set the Decimals. Set to 0. age will be an integer value.

5. Set the Label. Type Age of post-graduate student as the label value.

6. Set the Columns. Set this to 3.
The Variable View window should now look like this
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Now that we have defined the variable we can enter the following data
Name
Gender

Age

Alison
Female


23

Brian
Male


25

Christopher
Male


24

Danielle
Female


22

Edward
Male


29

Frank
Male


31

George
Male


27

Harriet
Female


26

Ingrid
Female


23

Jane
Female


25

You might like to save this data for later use. To do this select Save from the File menu,
navigate to the folder where you wish to store the data and then select Save.
	

	
	
	

	
	Inserting Variables and Data
It is often the case that after defining variables you realize that you need to add another. They can always be added after the last variable by simply typing the required information into the columns, but if you wish to insert a new variable amongst the existing variables you need to do the following…
Assume we need to add the variable smokes after the gender variable in our data set.
1. Switch to Variable View.

2. Select the variable age by clicking on the column number (3 in this case) as the new variable will be inserted before the currently selected variable
3. Select Insert Variable from the Data menu. A new variable with a default name will be inserted.

4. Assign the variable attributes (name, type etc) as appropriate. As this variable holds a yes/no value remember that u will have to set up the appropriate values.

After adding the variable the window should look something like the following (dependant upon your choice of names and labels)
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We will assume that the first 5 students are smokers and the remaining 5 non smokers. Switch to Data View and enter the appropriate data.

Adding Data
Similarly if we wish to add additional data it can be typed in directly after the last entry, but if we were to insert data for Carol, a female, smoker aged 22 before Christopher we would
1. Select the row number (3) for Christopher.

2. From the Data menu select Insert Cases.
3. Enter the data into the cells for the new record.

The data already entered into the grid can also be moved or copied to other positions by using the Cut, Copy and Paste commands (or the Keyboard shortcut equivalents CTRL + X, CTRL + C & CTRL + V) to move or copy the data into the new position. As before you can paste directly after the end of the data, but if you wish to place the data within the existing data you must “make room” for it by inserting cases via the Data/Insert Cases command.

In our example we wish duplicate the data for Christopher twice and rename the data for Alison to be Erica and position it after Edward. To achieve this we…

1. Select the data for Christopher by selecting on the row number (4)

2. Select Copy from the Edit menu or press CTRL+C
3. Select Insert Case from the Data menu twice to create 2 empty rows.

4. Select the first empty row and then select Paste from the Edit menu or press CTRL+V
5. Select the remaining empty row and then select Paste from the Edit menu or press CTRL+V
6. Change the name Alison to Erica.
7. Select Erica’s row by selecting on the row number.

8. Select Cut from the Edit menu or press CTRL+X
9. Select Frank’s row by selecting on the row number.

10. Select Insert Case from the Data menu

11. Select Paste from the Edit menu or press CTRL+V
Your data should now look as follows…
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Now that we have our data entered we can now move on to SPSS’s raison d'être…..

	

	
	
	

	
	Describing and Displaying Data
	

	
	
	

	
	SPSS has a plethora of functions to analyze your data and a full description of all of these if far beyond the scope of this simple tutorial, however we will cover a few of the basic operations you might need initially. Remember that’s SPSS has very good inbuilt Help should you need to go further.
	

	
	
	

	
	Numerical descriptions of data
	

	
	
	

	
	To produce a numerical description of the data entered earlier select Analyse->Descriptive Statistics->Descriptives… a dialog box similar to the following will be displayed
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Select the required variable(s) from the left hand list and move them to the Variable(s) list by clicking on the [image: image10.jpg]


 button. Clicking on the Options… button will display a further dialog box
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This dialog box allows you to select the required statistics. Once you have made your selection click Continue to return to the original dialog and then select OK. The SPSS viewer will display your results and you should see something similar to the following (dependent upon your variable and option selections)
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You can now Print, Save or Export you data for use in other applications via the File menu.

Descriptives give us very basic statistics of our data. More detailed statistics can be produced by selecting Analyze->Descriptive Statistics->Explore… a dialog similar to the following will be displayed
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Select the variable for analysis and any factoring or label variables (optional). You can elect to display Statistics, Plots or Both and clicking the Statistics…, Plots… and Options… buttons will display further dialog boxes that allow you to refine the results displayed. When you have entered your parameters select OK and the results will be displayed. 
	

	
	
	

	
	Graphical Descriptions of Data

It is often said that a Picture paints a thousand words, and displaying your data in graphical form can often help in explaining your results clearly and succinctly. SPSS offers a range of Charts and Graphs from the Graphs menu. In this section we will a chart and then learn how to enhance it by changing scales, labeling axis, changing fonts and colours etc. Note that SPSS uses the words “Chart” and “Graph” interchangeably.
	

	
	
	

	
	A Simple Chart
The method of creating any chart or graph is basically the same.

1. Enter the data.

2. Select the type of chart or graph that you want from the Graphs menu
3. Select the appropriate options to define how your chart/graph should appear

4. Select OK.

To create a Bar Chart to show the number of male and female students we do the following

1. Open the tutorial data set saved earlier.

2. Select the gender column.

3. Select Bar… from the Graphs menu. The following dialog box will be displayed…
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	4. Select Simple.
5. Select Summaries for groups of cases.
6. Select Define. This will display the following dialog box…
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	7. Select Gender of post-graduate student [gender] from the list and then select the arrow button to move the variable to the Category Axis.
8. Select OK. The following result will be displayed…
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	This is the basic output. We will now save the chart and then learn how to enhance it.
	

	
	
	

	
	Saving a Chart/Graph
	

	
	To save your chart for further use simply do the following…

1. Select Save from the File menu.

2. In the standard windows save dialog displayed navigate to the folder where you wish the chart to be saved.

3. Enter a suitable Filename.

4. Select OK.
	

	
	
	

	
	Editing a Chart/Graph
	

	
	You will notice that the basic chart is just that – very basic. We will now enhance it by adding titles, changing fonts and colours and changing the y axis scale.

The first step is to double-click in the chart to open the chart in SPSS’s Chart Editor window. The chart will be displayed as follows… 
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	Adding a Title and Subtitle

To add (or amend) a title…
1. Select Titles from the Chart menu. The Titles dialog will be displayed…
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	2. Type Frequency of Gender in the Title1 text box.

3. Type (Provisional) in the Subtitle text box.

4. Select Center from both the Title Justification and Subtitle Justification drop-down menus.

5 Select OK. The Title and Subtitle will appear on the chart…
	

	
	[image: image19.jpg]Count

Frequency of Gender

(Provisional)
7.2

7.04

6.84

6.64

644

6.24

6.04

58

Male Female

Gender of post-graduate student




	

	
	Changing Fonts

You can change the Font style or size of any of the text displayed on the chart in two ways.

1. Select the area of the chart containing the text you wish to change. When Text is selected a solid line is drawn around it.

2. To change the font you can either select Text from the Format menu or click the [image: image20.jpg]


 (Text) button on the toolbar. The Text Styles dialog is displayed…
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	3. Select the desired Font style and size from the list and then select Apply.
4. The text colour can be changed by selecting Color… from the Format menu and choosing the desired colour.

	

	
	Changing the Axes
SPSS names the x-axis the Category axis and the y-axis the Scale axis.
Modifying the Scale (y) Axis


1. Double-click on the label or line of the axis or select Axis from the Chart menu and then select Scale from the dialog displayed, followed by OK. The Scale Axis dialog is displayed…
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	2. Change the Axis Title to read Number.
3. Select Center from the Title Justification drop-down menu.

4. In the Range section enter 0 as the Minimum value and 10 as the Maximum value.

5. In the Major Divisions section enter 1 as the Increment.

6. Select the Labels… button. The Scale Axis:Labels dialog is displayed…
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	7. Enter 0 in the Decimal Places field and then select Continue.
8. Select OK.
	

	
	
	

	
	Modifying the Category (x) Axis
Modifying the x-axis is essentially the same as modifying the y-axis. 

1. Double-click on the label or line of the axis or select Axis from the Chart menu and then select Category from the dialog displayed, followed by OK. The Category Axis dialog is displayed…
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	2. Change the Axis Title to Gender.

3. Select Center from the Title Justification drop-down menu.

4. If you wish to change the labels select the Labels… button. The Category Axis:Labels dialog is displayed…
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	5. The Labels are changed by selecting the label in the list, entering the desired text into the Label text box and then selecting Change. The label Orientation and the frequency at which they are displayed can also be modified. Once you have made your changes select Continue.
6. Select OK.

The Bar style and fill pattern can also be changed by selecting the appropriate options from the Format menu. Experiment and see what changes can be made. It is worth remembering that the saying “Less is More” is often appropriate when designing graphs. Too much detail can often lessen the impact of the chart. Also bear in mind the use of colour – if you are not outputting to a colour device will you be able to differentiate between the colours you have used? Will the you chart lose some of its impact?
To complete your changes select Close from the File menu. You will be returned to the SPSS Viewer window with your changes made…
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Creating Pie Charts, Line Graphs, Scatter plots, Histograms etc all follow the same basic pattern, only the options available change from graph type to graph type. Graphs and charts can also be created via the Interactive… option of the Graph menu. This offers a slightly different method of creating graphs with options for applying pre-defined styles to the graph etc. Here experimentation is the key – try out the various options and discover what they do – and which is the way that you prefer to work.


	

	
	Exporting Charts
You may want to include your chart in another document (such as this). To do this select Export from the File menu. The Export Output dialog will be displayed…
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1. Select Charts Only from the Export drop-down menu.

2. Select Browse… and navigate to the folder in which you wish to save the output using the standard windows Save As dialog.

3. Select the desired File Type. (JPEG File will be Ok for all but the most specialised purposes). The Options… available will be dependent upon the File Type selected but it is best to leave these at their default values.

4. Select OK.
	

	
	
	

	
	Getting Help
	

	
	SPSS is a very complicated and capable computer program and this tutorial only touches on the very basics of working with SPSS. SPSS offers very comprehensive help and if you are unsure about how to achieve an objective it is always worthwhile investigating the help available. You can access help by pressing the F1 key or selecting Topics from the Help menu. The following dialog box will be displayed…
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Overview

SPSS for Windows provides a powerful statistical analysis and data
management system in a graphical enviranment, using descriptive
menus and simple dislog boxes to do most of the work for you. Most
tasks can be accomplished simply by pointing and clicking the mouse

In addition to the simple point-and-click interface for statistical
analysis, SPSS for windows provides:

Data Editor. & versatile spreadshest-like system for defining,
entering, editing, and displaying data.

Viewer. The Viewer makes it easy to browse your results,
selectively show and hide output, change the display order results,
and move presentation-quality tables and charts between SPSS and
other applications.

Multidimensional pivot tables. Your results come alive with
multidimensional pivot tables. Explare your tables by rearranging
rows, columns, and layers. Uncover impartant findings that can get
lost in standard reports. Compare groups easiy by splitting your
table 5o that only one group is displayed at a time.

High-resolution graphics. High-resolution, full-color pie charts, bar

v






	

	
	The Contents tab lists the major headings of the Help topics available. Clicking on the “+” icons will expand these subject headings further to provide a list of topics available. Selecting on a topic will display the help in the right-hand window pane. The Index tab gives an alphabetical list of all the help topics available. The Search tab allows you to enter words that may appear in the help topic, searching all possible help topics and presenting a list of those that meet your criteria. The Favourites tab allows you to save help topics that you might want to visit again, enabling you to find them quickly should you need to refer to them again.
SPSS also offers the following help from the Help Menu…

Tutorial

gives a short tutorial on all aspects of using SPSS.

Case Studies

shows actual examples of the application of SPSS.

Syntax Guide

gives help on SPSS’s programming language
Statistics Coach
takes you through procedures a step at a time.

There is also a lot of help available via the Internet. Entering SPSS into a search engine such as Google will return many sites that offer help and further tutorials. As the internet is a very ephemeral thing web pages are constantly changing. A link that night work today might not work tomorrow as so a list of web pages is not provided here, however on the day of writing a search of Google for SPSS provided 2,530,000 hits and most of the first 50 hits were further SPSS tutorials and help pages.

	

	
	
	

	
	
	








